av 19 hat den Parameter metadata_errors von av.open() entfernt; faster-whisper 1.2.1 ruft ihn auf -> TypeError bei jeder Transkription. Aufgefallen beim venv-Neuaufbau nach dem Upgrade auf Ubuntu 26.04 (Python 3.12 -> 3.14). DEPLOYMENT.md: Hinweis zum Pin und zum venv-Neuaufbau nach Release-Upgrades. Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com>
37 lines
1 KiB
TOML
37 lines
1 KiB
TOML
[project]
|
|
name = "voice-assistant-gateway"
|
|
version = "0.3.7"
|
|
description = "Modular voice assistant gateway with pluggable audio endpoints and provider adapters"
|
|
readme = "README.md"
|
|
requires-python = ">=3.11"
|
|
dependencies = [
|
|
"fastapi>=0.116.0",
|
|
"uvicorn[standard]>=0.35.0",
|
|
"httpx>=0.28.0",
|
|
"pydantic>=2.11.0",
|
|
"pydantic-settings>=2.10.0",
|
|
"python-multipart>=0.0.20"
|
|
]
|
|
|
|
[project.optional-dependencies]
|
|
test = [
|
|
"pytest>=8.0"
|
|
]
|
|
# Lokale KI-Module (optional, schwergewichtig): lokales STT via faster-whisper,
|
|
# lokales TTS via piper (in-process -> Modell bleibt geladen, kein Start pro Satz).
|
|
local = [
|
|
"faster-whisper>=1.0",
|
|
"piper-tts>=1.2",
|
|
# av>=19 kennt av.open(metadata_errors=...) nicht mehr -> faster-whisper 1.2.1
|
|
# crasht bei jeder Transkription (TypeError). Aufheben, sobald faster-whisper fixt.
|
|
"av<19"
|
|
]
|
|
|
|
[build-system]
|
|
requires = ["setuptools>=68", "wheel"]
|
|
build-backend = "setuptools.build_meta"
|
|
|
|
[tool.setuptools.packages.find]
|
|
where = ["."]
|
|
include = ["app*"]
|
|
exclude = ["deploy*", "tests*"]
|